How to get Netflix to run in VirtualBox on Ubuntu 12.04 without freezing!

First, do this.

So, my latest project has been to get Netflix! Well, I moved to Ubuntu a few weeks ago and alas Netflix has no Linux client. WTF!?

Well, I thought to myself, as I always do, “I should be able to get it running in a Virtual Machine!” And, once I got it up on Windowz XP, it loaded, then froze..and then again…and again.

So, after some Googling I found this solution. I tried it, and it worked for awhile, but then it froze…again. It basically has you set your DNS servers to Google’s (on the VM).

OpenDNS

I use OpenDNS, not Google. So, I thought that maybe I should give OpenDNS a try and changed my VM’s DNS to OpenDNS’s.

Now, I don’t know if this works because my host machine is with OpenDNS and my VM is on OpenDNS too, but it’s working right now.

Other Notes: Using Chrome on the VM, 3D hardware acceleration on the host, VM has 3 GB RAM and super-dooper tweaks I can’t remember. 

Can’t access Google Drive Folder Offline but can Online on Windows 7? [Fix]

Okay, so I have most of my files in a nice folder called Google Drive. Yep, all of em! I like the idea that my local copy will work just like any old folder and a copy of all my stuff will end up online as a backup. Yeah, I mostly like it as a backup, but I do use Google Docs alot, and it’s awesome that I can share loads of data with other Google users.

Well, today I go into one of my folders and, after a little syncing, I couldn’t access it. It basically gave one of those error messages like you see when you try and access a share when your offline. I wasn’t offline. So what the heck Google! Now, I could login online and access this folder, and (thankfully) it only had Google Doc stuff that Google Docs could handle.

Excuse my lazy hi-lighter job, but yeah, this was the folder acting up. I could access it online! So, I was able to work on the documents there anyways. So, after my meeting (yeah), I set out to fix it…. here’s what I did….

If you look, all I did was rename my folder (using Cygwin) with additional __ (underscores) at the end. I have no clue why this worked, but after I refreshed my Windows folder view…

Once I double-clicked it, it worked! If you are running into this, and trying to figure out if renaming the folder (has to be from Cygwin, Windows won’t let you) will kill your files….didn’t for me.

But, the really weird thing, so far, has been that, on Google Drive, the folder is still the same:

Go figure. As long as Google doesn’t delete my stuff, Google Drive has been awesome so far!